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1. Εισαγωγή & Περιοχή Μελέτης 
Στις 17 Ιουλίου 2023 ξεκίνησε μία πυρκαγιά στα Δερβενοχώρια Βοιωτίας, η οποία έκαψε 
συνολικά 95498 στρέμματα, σύμφωνα με την Ομάδα Άμεσης Χαρτογράφησης της 
Επιχειρησιακής μονάδας BEYOND του Εθνικού Αστεροσκοπείου Αθηνών (ΙΑΑΔΕΤ). 
 
Στη συγκεκριμένη άσκηση, θα χρησιμοποιήσουμε το ελεύθερα διαθέσιμο και ανοιχτού κώδικα 
λογισμικό QGIS, με σκοπό να χρησιμοποιήσουμε δορυφορικά δεδομένα, να τα επεξεργαστούμε 
και να χαρτογραφήσουμε την καμένη έκταση. 
 
 

2. Δορυφορικά δεδομένα Sentinel-2 
Για τη συγκεκριμένη άσκηση θα χρησιμοποιήσουμε δύο (2) δορυφορικές εικόνες από τον 
δορυφόρο Sentinel-2, μία (1) εικόνα πριν την πυρκαγιά και μία (1) εικόνα μετά την πυρκαγιά. 
Η πρώτη εικόνα λήφθηκε στις 14 Ιουλίου 2023 και η δεύτερη εικόνα λήφθηκε στις 29 Ιουλίου, 
αφού είχε τελειώσει η πυρκαγιά. 
 
Μπορείτε να κατεβάσετε τις εικόνες από το Copenicus Open Access Hub . Και οι δύο εικόνες 
είναι Level 2 και έχουν το ίδιο tile ID T34SGH. 
 

3. Εισαγωγή Sentinel-2 εικόνων στο QGIS & επεξεργασία 
Αρχικά, ανοίγουμε το QGIS και πατάμε Project > New.

https://scihub.copernicus.eu/dhus/#/home
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Έπειτα, πατάμε Layer > Add Layer > Add Raster Layer 

 
 

Κάτω από το “Source” πατάμε “…” και ψάχνουμε τον φάκελο με τις Sentinel-2 εικόνες. 

 
 

Για την εικόνα S2A_MSIL2A_20230714T090601_N0509_R050_T34SGH_20230714T140259.SAFE, 
ανοίγουμε το GRANULE > L2A_T34SGH_A042089_20230714T091057 > IMG_DATA > R10m. Στον 
φάκελο R10m διαλέγουμε τα αρχεία B02_10m.jp2, B03_10m.jp2, B04_10m.jp2, B08_10m.jp2. 
Αφού τα επιλέξουμε, πατάμε “Open” και στη συνέχεια “Add”. Ακολουθούμε την ίδια 
διαδικασία και για το … > IMG_DATA > R20m > Β12_20m.jp2.  
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Αφού κάνουμε τα παραπάνω βήματα, στο QGIS πρέπει οι εικόνες να φαίνονται όπως στην 
παρακάτω  εικόνα: 

 
 
Στη συνέχεια ψάχνουμε το εργαλείο “Build Virtual Raster” που βρίσκεται στο Raster > 
Miscellaneous. 
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Το εργαλείο “Build Virtual Raster” θα μας βοηθήσει να ενώσουμε τα πέντε διαφορετικά 
κανάλια σε μία εικόνα, ώστε να αρχίσουμε την επεξεργασία της. 
 
Στο “Input Layers” διαλέγουμε όλες τις εικόνες. 

 
Στο “Resolution” πατάμε το Highest, με σκοπό το Κανάλι 12 (B12) που έχει χωρική ανάλυση 
20μ να «κατέβει» στα 10μ χωρικής ανάλυσης και να ταιριάζει με τα υπόλοιπα κανάλια 
(B02,B03,B04,B08).  
 
Επιλέγουμε το “Place each input file into a separate band”. 
 
Επιβεβαιώνουμε πως το “Open output file after running algorithm” είναι επιλεγμένο.  
 
Τέλος, πατάμε “Run” 
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Αφού τρέξει η εντολή, αναμένουμε να δούμε την παρακάτω εικόνα στην οθόνη μας. 

 
 

Εφόσον έχουμε τρέξει επιτυχώς την εντολή, μπορούμε να σβήσουμε τις προηγούμενες εικόνες 
των καναλιών, καθώς η πληροφορία τους βρίσκεται στη νέα εικόνα. Για να το κάνουμε αυτό, 
πατάμε δεξί κλικ σε κάθε εικόνα > Remove Layer. 
 
Παρατηρώντας την εικόνα, τα χρώματα δε φαίνονται σωστά, διότι βλέπουμε μία ψευδέγχρωμη 
απεικόνιση. Για να δούμε το φυσικό έγχρωμο πατάμε δεξί κλικ στην εικόνα > Properties > 
Symbology. Εκεί αλλάζουμε: 
 

• Red Band: Band 3 

• Green Band: Band 2 

• Blue Band: 1 
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Τέλος, πατάμε «Run» και αναμένουμε την παρακάτω εικόνα. 

 
 
Μπορείτε να δοκιμάσετε και άλλες απεικονίσεις, όπως για παράδειγμα το ψευδέγχρωμο    RGB: 
B12 | B08 |  B04. 
 
Για να μειώσουμε τον χρόνο που χρειάζεται για να υλοποιηθεί κάθε εντολή, μπορούμε να 
περικόψουμε την εικόνα με το Raster > Extraction > Clip Raster by Extent. 
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Αφού ανοίξει η εντολή, επιλέγουμε στο Clipping Extent > Draw on Canvas και επιλέγουμε την 
ευρύτερη περιοχή των Δερβενοχωρίων στην Βοιωτία. Αν δεν είμαστε σίγουροι και σίγουρες για 
την περιοχή, μπορούμε να πάρουμε μία μεγαλύτερη περιοχή όπως φαίνεται στην παρακάτω 
εικόνα. 
 

 

 
Τέλος, πατάμε «Run» και περιμένουμε να υλοποιηθεί η εντολή. Αφού τρέξει η εντολή, 
αναμένουμε να δούμε το παρακάτω αποτέλεσμα. 
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Για να συνεχίσουμε σβήνουμε την εικόνα “Virtual” και πατάμε δεξί κλικ στην εικόνα 
“Clipped(extent)” > Ζoom to Layer. 
 
Για να αποθηκεύσουμε μία εικόνα, μπορούμε να πατήσουμε δεξί κλικ > Export > Save as. 
 
Στο “Format” επιλέγουμε GeoTIFF και στο “File Name” δίνουμε το όνομα “pre_fire” στην εικόνα.  
Πατάμε Ok και η πρώτη εικόνα πριν την πυρκαγιά είναι έτοιμη. 
 
Ακολουθούμε τα ίδια ακριβώς βήματα για την εικόνα μετά την πυρκαγιά. 
 
Σημειώσεις για την εικόνα μετά την πυρκαγιά 

• Στο “Build Virtual Raster” ΔΕΝ επιλέγουμε την εικόνα “pre_fire” 

• Στο βήμα για την περικοπή της εικόνας, μπορούμε να χρησιμοποιήσουμε το Clipping 
Extent > Calculate from Layer > pre_fire, έτσι ώστε οι δύο εικόνες να έχουν τις ίδιες 
διαστάσεις. 

• Τέλος, ονομάζουμε την δεύτερη εικόνα post_fire 
 
Αφού έχουν ολοκληρωθεί τα παραπάνω βήματα, το αποτέλεσμα πρέπει να μοιάζει σαν 
την εικόνα παρακάτω. 
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4. Χαρτογράφηση καμένων εκτάσεων με δορυφορικές εικόνες 
Sentinel-2 

Με σκοπό την χαρτογράφηση των καμένων εκτάσεων της πυρκαγιάς στα Δερβενοχώρια, θα 
χρησιμοποιήσουμε δύο τεχνικές. Η μία είναι αφαίρεση δεικτών και η  άλλη είναι η 
κατωφλίωση.  
 
Ουσιαστικά, θα υπολογίσουμε διάφορους δείκτες από τις δορυφορικές εικόνες 
πραγματοποιώντας απλές πράξεις μαθηματικών στα κανάλια και ,έπειτα, θα βάλουμε κάποιες 
συνθήκες όπως το μεγαλύτερο (>), το μικρότερο (<) ή και τον συνδυασμό των δύο (> και < ) με 
σκοπό να ανακτήσουμε πληροφορίες για τις καμένες εκτάσεις. 
 
Θα ξεκινήσουμε με έναν από τους πιο γνωστούς δείκτες που χρησιμοποιούνται στις πυρκαγιές, 
τον Normalized Burn Ratio (NBR). Όπως μάθαμε στις παρουσιάσεις, οι δείκτες είναι 
μαθηματικές πράξεις μεταξύ των διάφορων καναλιών για να αναδείξουμε διάφορες 
πληροφορίες. Ο NBR υπολογίζεται με τον παρακάτω τρόπο: 
 
 
 
 
 
 
Για να υπολογίσουμε τον δείκτη, πηγαίνουμε στο Raster > Raster Calculator και για κάθε εικόνα 
υπολογίζουμε τον δείκτη NBR, όπως φαίνεται στην εικόνα. 
ΥΠΕΝΘΥΜΙΣΗ: Στις εικόνες μας, pre_fire και post_fire, τα κανάλια B08 και B12 είναι τα 
pre_fire@4 / pre_fire@5 και post_fire@4/post_fire@5. 
Αποθηκεύουμε κάθε εικόνα ως “NBR_pre_fire” και “NBR_post_fire”.  
Επιβεβαιώνουμε πως κάτω από το “Raster Calculator Expression” γράφει “Expression Valid”.  
Πατάμε Ok. 
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Έχοντας υπολογίσει τους δύο δείκτες NBR, περιμένουμε η αρχική οθόνη μας να φαίνεται 
όπως παρακάτω. 

 

Ήδη μπορούμε να δούμε την καμένη έκταση να φαίνεται από τον δείκτη NBR, αλλά ακόμα δεν 
μπορούμε να εκτιμήσουμε την έκτασή της. 
 
Για να το κάνουμε αυτό, μπορούμε να κάνουμε μία απλή αφαίρεση μεταξύ των δύο εικόνων. Η 
προσέγγιση αυτή βασίζεται στο γεγονός πως μέσα στο χρονικό διάστημα των 12 ημερών 
μεταξύ των εικόνων μας (14 – 26 Ιουλίου) δεν θα έχουν πραγματοποιηθεί σημαντικές αλλαγές 
σε διάφορους τομείς όπως είναι η γεωργία (πότισμα αγροτεμαχίων, συγκομιδή), ο αστικός 
ιστός (αλλαγή στη δόμηση), αλλά έχει υπάρξει αλλαγή στην καμένη έκταση. Έτσι, αν 
αφαιρέσουμε την εικόνα πριν την πυρκαγιά από την εικόνα μετά την πυρκαγιά, μπορούμε να 
υπολογίσουμε στο περίπου την καμένη έκταση. 
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Για να το κάνουμε αυτό θα χρειαστούμε ξανά το Raster Calculator. Στο “Raster Calculator 
Expression” βάζουμε ” "NBR_pre_fire@1" - "NBR_post_fire@1"” και το αποθηκεύουμε ως 
dNBR. 
 
Επόμενο βήμα είναι να χρησιμοποιήσουμε το “Identify Features” για να δούμε τι τιμές έχει ο 
δείκτης στις καμένες εκτάσεις. 

 

Τώρα, θα πατάμε κλικ σε διάφορα σημεία της πυρκαγιάς για να δούμε τι τιμές έχει ο δείκτης. Η 
τιμή θα φαίνεται δεξιά στην οθόνη. Στην παρακάτω εικόνα φαίνεται ένα παράδειγμα με τιμή 
0.46 
 
Αφού κάνουμε κάποιες δοκιμές σε διάφορες περιοχές, μπορούμε να δούμε περίπου τις τιμές 
που έχει ο dNBR σε διάφορα σημεία της καμένης έκτασης. Με αυτό τον τρόπο μπορούμε να 
βρούμε ένα όριο (ή αλλιώς κατώφλι), πάνω από το οποίο ανιχνεύονται καμένες εκτάσεις. 
 
Για να συνεχίσουμε την άσκηση θα πάρουμε ως κατώφλι την τιμή 0.30. Ωστόσο, μπορείτε να 
χρησιμοποιήσετε διάφορες τιμές ως κατώφλι (είτε πιο χαμηλές 0.25, είτε πιο υψηλές 0.35) και 
να συγκρίνετε τα αποτελέσματα για να δείτε ποιο είναι πιο κοντά στην πραγματικότητα και τι 
διαφορές έχουν μεταξύ τους. 
 
Στο “Raster Calculator”  γράφουμε την έκφραση “"dNBR@1" > 0.30” , αποθηκεύουμε την 
εικόνα ως dNBR>0.30 και τρέχουμε την εντολή και αναμένουμε το παρακάτω αποτέλεσμα.
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Στη συνέχεια ακολουθούμε Raster > Conversion > Polygonize (Raster to Vector) και τρέχουμε 
την εντολή όπως είναι. 

 
Αφού ολοκληρωθεί η εντολή, περιμένουμε να δούμε την παρακάτω εικόνα. 
 

 

Ουσιαστικά, μετατρέψαμε ένα Raster αρχείο σε Vector, για να μπορέσουμε να πάρουμε τον 
αριθμό των δημιουργήσαμε ένα αρχείο με πολύγωνα, τα οποία είτε έχουν τιμή 1 (DN=1, που 
σημαίνει καμένη έκταση με βάση τον δείκτη NBR και την κατωφλίωση που κάναμε), είτε έχουν 
τιμή 0 (DN=0, όχι καμένη έκταση). 
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Ωστόσο, κοιτώντας την εικόνα βλέπουμε πως υπάρχει «θόρυβος», δηλαδή πολύγωνα που 
έχουν DN=1 εκτός της καμένης περιοχής. 
 
Για να επιλύσουμε αυτό το πρόβλημα, μπορούμε να σβήσουμε χειροκίνητα τα πολύγωνα 
εκτός της περιοχής μας (ή και να περικόψουμε την εικόνα μας με πιο αυστηρά όρια). 
 
Αρχικά, δεξί κλικ στο Layer που μετατρέψαμε σε πολύγωνο > Open Attribute Table > Show All 
Features > επιλέγουμε «Show Selected Features» και δεν ξεχνάμε να ενεργοποιήσουμε το 
«Toggle Editing Mode». 
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Παράλληλα, πατάμε δεξί κλικ στην μπάρα εντολών και ενεργοποιούμε το «Selection Toolbar», 
όπως φαίνεται στην παρακάτω εικόνα. 

 
 
 

Τέλος, μπορούμε να χρησιμοποιήσουμε το «Select Features by Area or Single Click”. Με το 
συγκεκριμένο εργαλείο, μπορούμε να επιλέγουμε τα πολύγωνα προς διαγραφή. Επιλέγουμε το 
πολύγωνο που θέλουμε να διαγράψουμε και πατάμε στο «Attribute Table», την επιλογή «Delete 
selected feature». 
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Αφού διαγράψουμε όσα πολύγωνα θέλουμε, είναι σημαντικό να πατήσουμε «Save Layer Edits». 
Για να κάνουμε μια προσέγγιση της καμένης έκτασης, κάνουμε δεξί κλικ στο Layer με τα 
πολύγωνα που επεξεργαστήκαμε > Open Attribute Table > Select Feature using an expression. 
 

(Σημείωση: στη συγκεκριμένη εικόνα το Layer ονομάζεται ‘Vectorized’, αλλά στα 
προηγούμενα παραδείγματα θα δείτε διαφορετικό όνομα ‘Burnt_Area_Vector’. Δεν αλλάζει κάτι 
στη διαδικασία). 

 
 

Τέλος, γράφουμε DN=1 και πατάμε “Select Features” όπως φαίνεται παρακάτω: 
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Στο Attribute Table μπορούμε να δούμε τον αριθμό των pixels που έχουν DN=1. Στο 
συγκεκριμένο παράδειγμα είναι 5245 (Selected=5245). 
 

 
 

 
Για να κάνουμε εκτίμηση της καμένης έκτασης, θα υπολογίσουμε το εμβαδό κάθε πολύγονου 
που έχει τιμή DN=1. Για να το κάνουμε αυτό ανοίγουμε το «Field Calculator» από το «Attribute 
Table» και ακολουθούμε τις παρακάτω οδηγίες. Αυτό θα μας δημιουργήσει μία νέα στήλη 
«Area», στην οποία βρίσκεται το εμβαδό εκφρασμένο σε τετραγωνικά μέτρα. 
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Τελευταίο βήμα είναι η χρήση του «Show Statistical Summary» για να δούμε τα στατιστικά της 
στήλης «Area» που υπολογίσαμε . 
 

 
Στο συγκεκριμένο παράδειγμα πήραμε ως αποτέλεσμα 67618600 τετραγωνικά μέτρα καμένης 
έκτασης, δηλαδή 6781 εκτάρια ή 67810 στρέμματα. 
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5. Αξιολόγηση Αποτελεσμάτων 
Το πιο σημαντικό ύστερα από κάθε εργασία που κάνουμε είναι να αξιολογούμε την 
μεθοδολογία και το αποτέλεσμά μας. Στη συγκεκριμένη περίπτωση, μπορούμε να 
χρησιμοποιήσουμε ως χάρτη αναφοράς, τον χάρτη καμένης έκτασης όπως προέκυψε από την 
Ομάδα Άμεσης Χαρτογράφησης της Επιχειρησιακής μονάδας BEYOND του Εθνικού 
Αστεροσκοπείου Αθηνών (ΙΑΑΔΕΤ). 

 

 
 

Βλέπουμε μία διαφορά 3000 εκτάρια/30000 στρέμματα από τη μέθοδο που χρησιμοποιήσαμε 
και την χαρτογράφηση της Επιχειρησιακής Μονάδας BEYOND του ΙΑΑΔΕΤ/ΕΑΑ. Μπορείτε να 
σκεφτείτε για ποιο λόγο συνέβη αυτό; (Σημείωση: επικεντρωθείτε στα όριο της κατωφλίωσης. 
Θα έπρεπε να είναι πιο χαμηλό ή πιο ψηλό;) 
 
Αυτή η διαδικασία που μάθατε είναι μια ενδεδειγμένη και εύκολη διαδικασία για να 
προσεγγίζουμε τις καμένες εκτάσεις, χρησιμοποιώντας ελεύθερα διαθέσιμα λογισμικά και 
δορυφορικά δεδομένα από το ευρωπαϊκό πρόγραμμα Παρατήρησης της Γης Copernicus και 
τους δορυφόρους Sentinel. 


