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1. Περιοχή Μελέτης 
Η περιοχή μελέτης η οποία θα μελετηθεί στο σημερινό εργαστήριο αφορά την επαρχία της Πάφου 

της Κύπρου και πιο συγκεκριμένα την περιοχή του Δάσους Πάφου. Το μεγαλύτερο κρατικό δάσος 

της Κύπρου είναι το Δάσος Πάφου με αποτέλεσμα η διατήρηση του και η διαρκής του 

παρακολούθηση αποτελεί ζωτικής σημασίας. 

 

2. Δεδομένα - Εγγραφή στην Υπηρεσία  
Τα δεδομένα Copernicus είναι ανοιχτά και σε ελεύθερη πρόσβαση σε όλους τους χρήστες με την 

προϋπόθεση να έχουν κάνει μια απλή και εύκολη εγγραφή στην Υπηρεσία. Για την περαιτέρω 

επεξεργασία των δορυφορικών χαρτών και δεδομένων, διατίθεται δωρεάν το λογισμικό SNAP από 

τον Ευρωπαϊκό Οργανισμό Διαστήματος (ESA). 

Χρήσιμες Συνδέσεις: 

Ανάκτηση δορυφορικών δεδομένων: https://scihub.copernicus.eu/ 

Λογισμικό SNAP: https://step.esa.int/main/download/snap-download/ 

Σε αυτό το σημείο πληκτρολογούμε στη μηχανή αναζήτησης την ιστοσελίδα 

https://scihub.copernicus.eu/ κι έπειτα με το ποντίκι, αριστερό κλικ στην επιλογή ‘Open Hub’. 

 

 

 

Εικόνα 1: Αρχική εικόνα ιστοσελίδας Copernicus 

https://scihub.copernicus.eu/
https://step.esa.int/main/download/snap-download/
https://scihub.copernicus.eu/
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Στη συνέχεια, πατάμε με το ποντίκι μας το εικονίδιο για να εισέλθουμε στην υπηρεσία. 

Πατώντας, με το ποντίκι μας, την επιλεγμένη με κόκκινο χρώμα εικόνα, ανοίγει ένα καινούργιο 

παράθυρο διαλόγου. 

Όταν εμφανιστεί λοιπόν το νεο παράθυρο διαλόγου, συμπληρώνουμε όλα τα απαραίτητα πεδία για 

να δημιουργήσουμε τον δικό μας λογαριασμό ούτως ώστε να μπορούμε να αποκτήσουμε δωρεάν 

δεδομένα. Προσοχή → το ηλεκτρονικό ταχυδρομείο (e-mail) το οποίο θα δηλώσουμε να είναι 

έγκυρο λόγω του ότι θα μας επιστραφεί ηλεκτρονικό μήνυμα από την υπηρεσία για επιβεβαίωση. 

 

 

Εικόνα 3: Εγγραφή στην υπηρεσία 

Αφού ολοκληρωθεί η εγγραφή, πραγματοποιούμε την είσοδο μας στην Υπηρεσία με το όνομα 

χρήστη που δημιουργήσαμε και τον κωδικό. 

Εικόνα 2: Δημιουργία λογαριασμού στην ιστοσελίδα Copernicus 
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3. Μέθοδος ανάκτησης δορυφορικών δεδομένων  
 
Η μεθοδολογία ξεκινάει πρώτα με την ανάκτηση των δορυφορικών δεδομένων από την ιστοσελίδα 

https://scihub.copernicus.eu, η οποία παρέχει στο κοινό δορυφορικά δεδομένα  δωρεάν για τους 

χρήστες. Πιο συγκεκριμένα, παρέχει ελεύθερα όλα τα προϊόντα του Sentinel-1, Sentinel-2, Sentinel-3 

και Sentinel-5P. Για το σημερινό εργαστήριο θα χρησιμοποιηθούν εικόνες Sentinel-2 από 13 Απριλίου 

2021, 3 Μαΐου 2022 και 1 Αυγούστου 2023.  

 

ΌΛΑ ΕΤΟΙΜΑ, ΞΕΚΙΝΑΜΕ  

 

Πρώτο βήμα→ Σχηματίζουμε ένα πολύγωνο επάνω από την περιοχή μελέτης μας πατώντας το 

σύμβολο δεξιά στην οθόνη μας (φαίνεται στο κόκκινο κουτί στην παρακάτω εικόνα) ή δεξί κλικ στην 

περιοχή που μας ενδιαφέρει και σύρουμε από το ένα σημείο στο άλλο μέχρι να σχηματιστή το 

πολύγονο. Για τους σκοπούς της άσκησης η περιοχή μελέτης, αφορά την επαρχεία Πάφου και πιο 

συγκεκριμένα το δάσος Πάφου.  

 

Δεύτερο βήμα→ Καθορισμός των παραμέτρων που θα συμπληρωθούν για να κατεβάσουμε ορθά την 

εικόνα. 

Επιλέγουμε το sensing period το οποίο αφορά τις ημερομηνίες 

• Sensing period → 2021/04/13, 2022/05/03 και 2023/08/01 

• Product Type    →S2MSI2A 

Το προϊόν επιπέδου (Level-2A) παρέχει ατμοσφαιρικά διορθωμένες εικόνες Επιφανειακής Ανάκλασης 

(SR), που προέρχονται από τα σχετικά προϊόντα Level-1C. 

 

 

Εικόνα 4: Eίσοδος στην υπηρεσία 

https://scihub.copernicus.eu/
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• Cloud Cover      → [0 TO 10] 

Εικόνα 5: Εισαγωγή παραμέτρων για την λήψη της εικόνας Sentinel-2 

 

Συμπληρώνοντας σωστά τις παραμέτρους κάνουμε κλικ στο κουμπί της αναζήτησης. Σε αυτό το 

σημείο εμφανίζεται η εικόνα που θέλουμε να κατεβάσουμε με συνολικό μέγεθος 651 MB και 

κάνουμε κλικ στο link όπως φαίνεται μέσα στο κόκκινο κουτί στην Εικόνα 4.  

 

Εικόνα 6: Τρόπος λήψης εικόνας Sentinel-2 

*Αυτό γίνεται για όλες τις ημερομηνίες που επιλέχθηκαν για το σημερινό εργαστήριο. 
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4. Εισαγωγή δορυφορικής εικόνας στο λογισμικό SNAP (Open 

product) 
Αφού αποθηκεύσουμε την δορυφορική εικόνα μας στον φάκελο που εμείς θα καθορίσουμε στον 

υπολογιστή μας, ανοίγουμε το λογισμικό επεξεργασίας δορυφορικών εικόνων SNAP. Στο περιβάλλον 

που εμφανίζεται για να εισαχθεί η δορυφορική εικόνα, σύρουμε και αφήνουμε (drag & drop) την 

εικόνα μας μέσα στο λογισμικό. Εναλλακτικά εισαγωγή των εικόνων μας μπορεί να γίνει με την 

επιλογή “File → Open Product” πηγαίνοντας στον φάκελο όπου αποθηκεύσαμε την εικόνας μας τα 

οποία είναι τύπου compressed (zipped) folders και πατάμε στο ‘’Open’’ (Εικόνες 8-9). 

  

 

 

 

 

 

 
Εικόνα 8: Τρόπος εισαγωγής δορυφορικής 
εικόνας 

Εικόνα 7: Άνοιγμα εξερευνητή αρχείων 

Εικόνα 9: Επιλογή αρχείων και εισαγωγή 
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5. Άνοιγμα δορυφορικής εικόνας (RGB Image Window) 
Για να ανοίξει η δορυφορική μας εικόνα πατάμε δεξί κλικ στην εικόνα μας όπου ένα νέο 

παράθυρο εμφανίζεται και πατάμε κλικ στο Open RGB Image Window (Εικόνα 10). 

 

 

 

 

 

 

 

 

 

 

 

Αφού ανοίξει το νέο παράθυρο στο σημείο Profile επιλέξτε Sentinel 2 MSI Natural Colors 

και μετά ΟΚ όπως φαίνεται στην Εικόνα 11. 

  

 

 

 

 

 

 

 

 

  

 
 

Εικόνα 10: Άνοιγμα δορυφορικής εικόνας Sentinel-2 στο λογισμικό SNAP 

Εικόνα 11: Καθορισμός προφίλ εικόνας 
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6. Γράφημα Μεθοδολογίας (Graph builder) και Μαζικής 

Επεξεργασίας (Batch Processing) 
 

Για να αποφύγουμε την επεξεργασία των δεδομένων μία προς μία εικόνα θα 

χρησιμοποιήσουμε το εργαλείο Graph Builder. Επιλέγουμε το Tools → GraphBuilder (Εικόνα 

12). Όταν επιλεγεί το GraphBuilder ένα νέο παράθυρο θα εμφανιστεί στο οποίο θα 

εισάγουμε διάφορα εργαλεία (Εικόνα 13).  

 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Εικόνα 12: Τρόπος για άνοιγμα GraphBuilder 

Εικόνα 13: Παράθυρο GraphBuilder 
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Ακολουθούμε τα παρακάτω βήματα: 

Προηγείται το κομμάτι της επαναδειγματοληψίας (resample) όπου θα πρέπει να μετατραπεί η χωρική 

ανάλυση όλων των καναλιών σε όλες τις εικόνες σε 20 μέτρα. Πατήστε δεξί κλικ στο Read→ Add 

→Raster→Geometric→ Resample (Εικόνα 14) και μετά ενώνουμε το Read με το Resample (όταν το 

ποντίκι σας βρίσκεται πάνω από το read θα εμφανιστεί ενα κόκκινο χαρακτηριστικό και τότε σύρουμε 

προς το resample για να ενωθούν). 

 

 

Εικόνα 14: Επιλογή Resample 

 

Αφού προσθέσουμε και ενώσουμε το resample πατάμε δεξί κλικ στο φόντο Add → Raster→ Subset 

για να προσθέσουμε το Subset (Εικόνα 15). Σε αυτό το σημείο ενώνουμε με τον ίδιο τρόπο που 

ειπώθηκε στο προηγούμενο βήμα αλλά αυτή την φορά το Resample με το Subset. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Εικόνα 15: Προσθήκη Subset 
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Για την προσθήκη BandMath θα χρειαστεί να πατήσουμε δεξί κλικ στο φόντο Add → Raster → 

BandMaths (Εικόνα 16) 

 

 

 

 

 

 

 

 

 

 

Αφού ολοκληρωθεί το πιο πάνω βήμα, πατάμε δεξί κλικ στο φόντο  Add →Raster →  BandMerge. Σε 

αυτό το σημείο ενώνουμε το Subset με το BandMaths και το BandMerge. Στην συνέχεια ενώνουμε 

το BandMath με το BandMerge. Τέλος, ενώνουμε το ΒandMerge με το Write (Εικόνα 17).  

  

 

 

 

 

 

 

 

 

 

 

Στην Εικόνα 18 θα δείτε πως πρέπει να μοιάζει το σχεδιάγραμμα μας. Σε αυτό το σημείο πρέπει να 

αποθηκεύσουμε αυτά που έχουμε κάνει, επομένως πατήστε SAVE. 

 

 

 

 

 

Εικόνα 16: Προσθήκη Band Math 

Εικόνα 17: Προσθήκη BandMerge 
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Εικόνα 18: Τελικό σχεδιάγραμμα 

 

Η μαζική επεξεργασία (Batch Processing) είναι όταν ένας υπολογιστής επεξεργάζεται έναν αριθμό 

εργασιών που έχει συλλέξει σε μια ομάδα. Έχει σχεδιαστεί για να είναι μια πλήρως 

αυτοματοποιημένη διαδικασία, χωρίς ανθρώπινη παρέμβαση. Στην δική μας περίπτωση μας 

εξυπηρετεί λόγω του ότι έχουμε 3 εικόνες, επομένως η επεξεργασία μίας-μίας εικόνας είναι 

χρονοβόρα. Κλικ Tools→ Batch Processing (Εικόνα 19). 

 

 

 

 

 

 

 

 

 

 

 

 

Αφού ανοίξει το παράθυρο της μαζικής επεξεργασίας κάνετε κλικ στο σύμβολο + (Add) (Εικόνα 20). 

Όταν εμφανιστούν οι εικόνες μας κλικ Load Graph και εισάγετε το αρχείο που αποθηκεύσατε στην 

διαδικασία του GraphBuilder. 

Εικόνα 19: Άνοιγμα μαζική επεξεργασία (Batch 
Processing) 
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Εικόνα 20: Εισαγωγή των εικόνων μας 

 

Το επόμενο βήμα αφορά την επαναδειγματοληψία (resample) πιο συγκεκριμένα η μετατροπή της 

χωρικής ανάλυσης όλων των καναλιών σε 20 μέτρα στην δική μας περίπτωση. Αυτό προσαρμόζεται 

μέσω των καναλιών και εφαρμόζεται με τον πιο κάτω τρόπο:  

➢ Κάνουμε κλικ στο Resample στην γραμμή επιλογών. 

➢ Επιλέγουμε την επιλογή By reference band from source product → πατάμε το βελάκι στα δεξιά 

και επιλέγουμε την Β11. Αυτό υποδηλώνει ότι τo κανάλι Β11 το οποίο έχει χωρική ανάλυση 20 

μέτρα από το οποίο όλα τα υπόλοιπα κανάλια του δορυφόρου θα μετατραπούν στην ίδια χωρική 

ανάλυση με αυτό, δηλαδή στα 20 μέτρα ανά εικονοστοιχείο (pixel). 

➢ Προχωράμε πιο κάτω και στην επιλογή down sampling method και διαλέγουμε το Mean.     

 

Αφού ολοκληρώσουμε το κομμάτι του Resample προχωράμε στην καρτέλα Subset και στο source 

band επιλέξτε B4, B8, B11 & B12. To Subset μας βοηθά να επιλέξουμε το τί θέλουμε σε μια εικόνα 

στην δική μας περίπτωση είναι ο δείκτης βλάστησης.  

Εικόνα 21: Eπαναδειγματοληψία (resample) 
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Εικόνα 22: Subset 

Προχωράμε στην καρτέλα BandMaths και πληκτρολογήστε στο target Band NDVI. Στο σημείο No-Data 

Value πληκτρολογήστε NaN. Κάνουμε κλικ Edit expression. Στο expression εισάγουμε τον τύπο (Β8-

Β4)/(Β8+Β4) και κάνουμε κλικ ΟΚ (Εικόνα 23).  

 

 

 

 

 

 

 

 

 

 

Εικόνα 23: Εισαγωγή του δείκτη βλάστησης NDVI 
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Κάνουμε κλικ στο BandMerge όπου βλέπουμε την εικόνα μας και τα κανάλια που έχουμε επιλέξει. 

Σε αυτό το βήμα δεν αλλάζουμε κάτι. 

 

  

 

 

 

 

 

 

Τέλος, επιλέγουμε το Write όπου θα αποθηκεύσουμε την εικόνα μας σε μορφή GeoTIFF την οποία 

έχει γίνει επαναδειγματοληψία (resampled) (Εικόνα 25). Αυτό σημαίνει ότι θα μετατραπεί η χωρική 

ανάλυση όλων των καναλιών στα 20 μέτρα. Κλικ RUN και περιμένουμε. 

 

 

 

 

 

 

 

 

 

 

 

 

Εικόνα 24: Αλλαγές που έγιναν στον αρχείο μας 

Εικόνα 25: Αποθήκευση του αρχείου επαναδειγματοληψίας (resample) 

Εικόνα 26: Τελικό προϊόν των εικόνων μας και εδώ φαίνεται ο δείκτης NDVI 
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7. Ταξινόμηση (Classification) με την χρήση qGIS 
*Η διαδικασία που θα ακολουθήσει γίνεται για την κάθε εικόνα ξεχωριστά  
(Οπότε στην κάθε εικόνα που θα αποθηκεύσουμε μετά την επεξεργασία της, πρέπει να βάζουμε την 

σωστή ημερομηνία). 

 

Ο ορισμός της ταξινόμησης περιλαμβάνει την συστηματική διάταξη αντικειμένων σε ομάδες ή 

κατηγορίες σύμφωνα με καθορισμένα κριτήρια. Στην συγκεκριμένη μελέτη είναι χρήσιμο για τον 

καθορισμό δέντρων και μη δέντρων. Πιο συγκεκριμένα θα έχουμε την ικανότητα να προσδιορίσουμε 

αν βλέπουμε δέντρα η αν αυτό που βλέπουμε από την εικόνα μας και πιο συγκεκριμένα από τα Pixels 

μας δεν είναι δέντρα αλλά κάτι άλλο. Για να ξεκινήσει η διαδικασία ταξινόμησης με την χρήση του 

προγράμματος QGIS ακολουθούμε τον παρακάτω σύνδεσμο για να εγκαταστήσουμε το πρόγραμμα 

στον υπολογιστή μας. →  https://www.qgis.org/en/site/  

 

Αφού το εγκαταστήσουμε, πλέον είμαστε σε θέση να το χρησιμοποιήσουμε και να ξεκινήσουμε. 

Ανοίγουμε το λογισμικό QGIS. Θα βλέπουμε την αρχική σελίδα (Εικόνα 27).   

 

 

Αφού ανοίξουμε το QGIS κάνουμε κλικ στο νέο έργο (New Project) για να δημιουργήσουμε το δικό 

μας έργο. Κάνουμε κλικ στο φάκελο πάνω αριστερά θα εμφανιστεί ένα νέο παράθυρο. Σε αυτό το 

σημείο θα πάμε να βρούμε εκεί που έχουμε αποθήκευση το αρχείο resampled το οποίο 

δημιουργήσαμε στο SNAP και κάνουμε κλικ upload (Εικόνα 28) ή μπορούμε από το file explorer να 

βρούμε το αρχείο και να το σύρουμε και να το αφήσουμε στο πρόγραμμα του QGIS (Εικόνα 29). 

 

 

 

 

Εικόνα 27: Λογισμικό qGIS 

https://www.qgis.org/en/site/
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Εικόνα 28: Τρόποι ανοίγματος φακέλων στο QGIS 

 

 

 

 

 

 

 

 

 

 

 

Το αποτέλεσμα που θα έχουμε, περίπου θα μοιάζει σαν την Εικόνα 30 πιο κάτω. 

Εικόνα 29: Τρόποι ανοίγματος φακέλων με τον τρόπο drag and drop στο QGIS 
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Σε αυτό το σημείο πατάμε δεξί κλικ στο αρχείο μας→ επιλέγουμε Properties (Εικόνα 31).  

Το νέο παράθυρο που θα ανοίξει θα σιγουρευτούμε ότι βρισκόμαστε στο Symbology (Αριστερά 

στην εργαλειοθήκη). Στην συνέχεια επιλέγουμε: 

a) Στο Render Type → Singleband gray  

b) Gray band → Band 5 

c) Color gradient → White to Black 

d) Ορίζουμε τιμή → Για τον δείκτη βλάστησης NDVI οι τιμές κυμαίνονται από -1 σε 1 

e) Μπορούμε επίσης να θέσουμε χρώμα στην εικόνα κάνοντας κλικ στο colorized και μετά στο 

βελάκι δίπλα (Εικόνα 32) 

f) Όταν ολοκληρωθεί η διαδικασία αυτή κάνουμε κλικ στο Apply και μετά OK 

  

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Εικόνα 30: Εμφάνιση επεξεργασμένης (Subset) εικόνας από το SNAP 

Εικόνα 31: Επιλογή ιδιοτήτων της εικόνας μας 
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Εικόνα 32: Ορισμός απόδοσης καναλιών του NDVI 

 

 

  

 

Εικόνα 33: Πώς θα φαίνεται η εικόνα μας 
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8. Δημιουργία περιοχής μελέτης 
Όπως αναφέραμε πριν η περιοχή μελέτης μας, αφορά το Δάσος Πάφου. Η εικόνα που έχουμε 

ανακτήσει αφορά το δυτικό μέρος της Κύπρου οπόταν η κοπή της εικόνας στο σημείο 

ενδιαφέροντος είναι απαραίτητη. Για να επιτευχθεί αυτό πρέπει να ακολουθήσουμε τα 

παρακάτω βήματα ξεκινώντας από την δημιουργία νέου shapefile. Κάνουμε κλίκ στο Layer 

(Πάνω αριστερά στην εργαλειοθήκη) → Create Layer → New Shapefile Layer (Εικόνα 34). 

 

Εικόνα 34: Δημιουργία νέου στρώματος 

 

Για να δημιουργήσουμε νέο shapefile κάνουμε κλικ στις 3 τελείες στα δεξιά (Εικόνα 35) του File name. 

Θα σας εμφανίσει ένα νέο παράθυρο για να αποθηκεύσετε το shapefile σας→ ονομάστε το 

area_of_interest. Στην συνέχεια επιλέγουμε το είδος σχήματος που επιθυμούμε επιλέξτε στο 

Geometry την επιλογή Polygon. Στην συνέχεια στο Additional Dimensions επιλέγουμε τις διαστάσεις 

που αναγράφονται κάτω δεξιά τις εικόνας 35. Πατάμε OK.  
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Εικόνα 35: Τρόπος δημιουργίας πολυγώνου 

 

Θα μας εμφανιστεί η δημιουργία του νέου shape file στο αριστερό παράθυρο. 

 

 

 

 

 

 

 

 

 

  

 

Για να πραγματοποιηθεί η δημιουργία πολυγώνου κάνουμε κλικ στο μολύβι και μετά το πολύγωνο. 

(Δες εικόνα 37)  

Εικόνα 36: Δημιουργία περιοχής ενδιαφέροντος 



 

22 
 

Κλικ στην περιοχή που μας ενδιαφέρει (Δάσος Πάφου). Δημιουργούμε ένα πολύγωνο. Διπλό κλικ 

στο πολύγωνο όπου θα εμφανιστεί ένα παράθυρο → εισάγουμε id με τον αριθμό 1 και πατάμε ΟΚ 

(Εικόνα 38). 

Πατάμε αποθήκευση αλλαγών (Εικόνα 39). 

 

 

 

 

 

 

 

 

Εικόνα 37: Δημιουργία πολυγώνου 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Στην συνέχεια πατάμε δεξί κλικ στο αρχείο area of interest (που θα βρίσκουμε αριστερά στο 

παράθυρο με τα αρχεία δηλαδή το area of interest  →properties →symbology και επιλέγουμε ότι 

δείχνει η εικόνα 40. Στη συνέχεια κλικ Apply και OK. 

 

Εικόνα 38: Δημιουργία πολυγώνου στον χάρτη μας και εισαγωγή ID 

Εικόνα 39: Αποθήκευση πολυγώνου 
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Εικόνα 40: Χρωματισμός πολυγώνου 

 

Έτσι θα φαίνεται η εικόνα στον υπολογιστή μας (Εικόνα 41): 

 

 

Εικόνα 41: Ολοκλήρωση δημιουργίας πολυγώνου 
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Αφού δημιουργήσουμε το πολύγωνο στο σημείο που μας ενδιαφέρει να μελετήσουμε, προχωράμε 

στο επόμενο βήμα που αφορά την αποκοπή της εικόνας μας. Για να επιτευχθεί αυτό κάνουμε κλικ 

Raster→ Extraction→ Clip Raster by Extent (Εικόνα 42). 

Στην συνέχεια αφού ανοίξει το νέο παράθυρο ακολουθούμε τα πιο κάτω βήματα: 

• Στο input layer εισάγουμε την εικόνα μας η οποία έγινε resamble από το SNAP.  

• Στο Clipping extent επιλέγουμε το area of interest που δημιουργήσαμε εδώ 

• Clipped extent→ save file (αποθηκεύουμε ως clipped_NDVI) (Δες εικόνα 38) 

• Τέλος, πατήστε RUN 

(Δες εικόνα 44) 

 

 

 

 

 

Εικόνα 43: Δημιουργία κοπής εικόνας 

Εικόνα 42: Αποθήκευση της νέας εικόνας η οποία περιέχει μόνο την περιοχή μελέτης 
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Εικόνα 44: Αποθήκευση επεξεργασμένης εικόνας 

 

Αφού ολοκληρώσουμε το βήμα αποκοπής, προχωράμε στην εισαγωγή της αρχικής εικόνας που 

ανακτήσαμε από το SciHub Copernicus και είναι σε μορφή αρχείου (zip). Αυτό γίνεται για να έχουμε 

οπτική επαφή για τη δημιουργία σημείων που θα δείχνουν αν είναι δάσος ή όχι.  Βρείτε το μέρος που 

αποθηκεύσατε αυτές τις εικόνες και σύρουμε και αφήνουμε στο QGIS (Δες εικόνα 45). 

 

Εικόνα 45: Εισαγωγή zip αρχείου 
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Μόλις εισαχθεί το αρχείο, θα εμφανιστεί αυτό το παράθυρο (Εικόνα 46), πατάμε την επιλογή που 

φαίνεται στην εικόνα 46 και κλικ Add Layer. 

 

Εικόνα 46: : Εισαγωγή zip αρχείου και επιλογή στρωμάτων 

 

9. Εκπαίδευση μοντέλου με το εργαλείο ταξινόμησης Gaussian 

Mixture Model  
 

Τα μοντέλα μείγματος Gaussian είναι ένα πιθανό μοντέλο για την αναπαράσταση κανονικά 

κατανεμημένων υποπληθυσμών σε έναν συνολικό πληθυσμό. Τα μοντέλα μείγματος γενικά δεν 

απαιτούν να γνωρίζουν σε ποιον υποπληθυσμό ανήκει ένα σημείο δεδομένων, επιτρέποντας στο 

μοντέλο να μαθαίνει αυτόματα τους υποπληθυσμούς.  

Στην συνέχεια θα δημιουργήσουμε ένα νέο shapefile στο οποίο θα επιλέξουμε την δημιουργία points 

για τον καθορισμό του δάσους και μη δάσους και την εκπαίδευση του μοντέλου μας. Κάνουμε κλικ 

Layer→ Create Layer→ New Shapefile Layer  (Εικόνα 47). 

 

 

Εικόνα 47: Δημιουργία Shapefile 
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Στο File name αποθηκεύουμε το μοντέλο μας με το όνομα train2023. Προχωράμε στο Geometry type 

όπου επιλέγουμε το MultiPoint. Το κομμάτι του New Field πληκτρολογούμε στο Name το όνομα class. 

Αλλάζουμε το Type σε 123 Integer (32bit) και μετά Add to Fields List. Κάνουμε κλικ ΟΚ.  

Κάνουμε κλικ στο μολύβι και μετά στις κουκκίδες (Εικόνα 48). 

 

 

Εικόνα 48: Δημιουργία πολλαπλών σημείων για την εκπαίδευση μοντέλου 

Κάνουμε μεγέθυνση στην εικόνα μας μέχρι να δούμε μικρά τετράγωνα τα οποία ονομάζονται pixels 

και πατάμε αριστερό κλικ στο σημείο που μας ενδιαφέρει. Εισάγουμε ID και class → OK. (* Το class 

ορίστε το έως 1 το οποίο θα ανταποκρίνεται στο δάσος και 2 το οποίο θα είναι το μη δάσος) (Εικόνα 

49) 

*Κάνουμε περίπου 15-20 points για το δάσος και 15-20 points για το μη δάσος. 

 

 

 

 

Εικόνα 49: Χαρακτηρισμός δάσους και μη δάσους μεγεθύνοντας την εικόνα μας για να βλέπουμε τα pixels 
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Στο class στο οποίο χαρακτηρίσαμε το δάσος και μη δάσος μπορούμε στην συνέχεια να αλλάξουμε 

τους χρωματισμούς. Κάνουμε κλικ στο Classify όπου θα μας εμφανίσει το 1 και το 2. Στο Legend δίπλα 

από το 1 πληκτρολογούμε forest (Δάσος) και δίπλα στο 2 no forest (Μη δάσος) και μετά ΟΚ (Εικόνα 

50) 

 

Εικόνα 50: Προσαρμογή χρωμάτων 

Περίπου έτσι θα μoιάζει η εικόνα μας (Εικόνα 52) 

 

 

 

 

 

 

 

 

 

 

Για την εκπαίδευση του μοντέλου μας με τον αλγόριθμο Gaussian Κλικ processing (πάνω δεξιά) → 

Toolbox και θα σας εμφανίσει νέο παράθυρο στην δεξιά πλευρά της οθόνης μας.   

Στο κενό της αναζήτησης Πληκτρολογούμε dzetsaka → επιλέγουμε Train Algorithm.  

Το dzetsaka είναι εργαλείο ταξινόμησης όπου επιτρέπει την εκπαίδευση μοντέλων με διάφορους 

αλγορίθμους όπως για παράδειγμα το Gaussian. 

 

Εικόνα 51: Διαχωρισμός κλάσεων με χρώματα 
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Εισάγετε (Εικόνα 53): 

• Input Raster → εισάγουμε την αποκομμένη εικόνα (clip_ndvi) που δημιουργήσαμε 

• Input layer → εισάγουμε το train που δημιουργήσαμε 

• Field → 123class 

• Select algorithm to train →επιλέγουμε Gaussian Mixture Model 

• Pixels για επικύρωση πληκτρολογούμε →20  

• Output model → αποθηκεύουμε το μοντέλο μας ως model (χρονολογία της εικόνας που 

επεξεργάζεστε).txt 

• Κλικ RUN 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Εικόνα 52: Εκπαίδευση αλγορίθμου με την χρήση dzetsaka 

Εικόνα 53: Εκπαίδευση μοντέλου 
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Αφού ολοκληρώσουμε την εκπαίδευση συνεχίζουμε στην δημιουργία του μοντέλου πρόγνωσης 

(predict model). Στο processing toolbox επιλέγουμε από το dzetsaka το Predict model (Εικόνα 54). 

 

 

 

 

 

 

 

 

 

 

Στη συνέχεια για την δημιουργία της ταξινόμησης ακολουθούμε τα πιο κάτω βήματα (Εικόνα 55): 

• Input raster→ βάζουμε τον φάκελο clipped_NDVI 

• Στο Model learned→ βάζουμε τον φάκελο που αποθηκεύσαμε στο train algorithm (model και 

χρονολογία)  

• Output raster→ αποθηκεύουμε το αποτέλεσμα της εικόνας μας ως classified (με την 

χρονολογία που δουλεύουμε) 

• Κλικ RUN  

 

 

 

 

 

 

 

 

 

 

 

  

 

 

Εικόνα 54: Επιλογή μοντέλου πρόγνωσης (predict model) 

Εικόνα 55: Δημιουργία ταξινόμησης 
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Τέλος κάνουμε δεξί κλικ στο classified που δημιουργήσαμε και επιλέγουμε το properties. Στο 

symbology επιλέγουμε τα πιο κάτω (Εικόνα 56):  

• Render Type→ Paletted/Unique values 

• Band→ Band 1 (Gray) 

• Κλικ classify και το (+) για να μας εμφανίσει τα values 1 και 2 

• Color κλικ πάνω στο color και αλλάζουμε χρώματα για να μπορεί να φανεί η διαφορά 

• Κλικ Apply και μετά OK  

 

Εικόνα 56: Αλλαγές χρωμάτων 

 

10. Αποτελέσματα αποψίλωσης για τις χρονολογίες 2021, 2022 και 

2023 
Τα αποτελέσματα μας θα μοιάζουν περίπου σαν τις εικόνες πιο κάτω. 
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Όπως βλέπουμε από τις εικόνες πιο πάνω μπορούμε να διακρίνουμε τις αλλαγές που υπήρξαν με το 

πέρασμα του χρόνου. Στην επεξεργασμένη εικόνα από το 2021 μπορούμε να δούμε την πυκνότητα 

του δάσους. Ένα χρόνο μετά όπως φέρνετε στην εικόνα του 2022 το δάσος έχει μειωθεί σε κάποια 

σημεία. Τέλος στην εικόνα του 2023 υπάρχει αρκετή διαφορά από τις προηγούμενές εικόνες 

απεικονίζοντας μας την σοβαρή μείωση του δάσους. 

Εικόνα 57: Τελικές εικόνες 
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