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1. Εισαγωγή & Περιοχή μελέτης 
Η επιφάνεια του εδάφους αντιπροσωπεύει έναν από τους βασικούς παράγοντες για την 

αξιολόγηση των περιβαλλοντικής αλλαγών.  

Οι δραστηριότητες παρακολούθησης των αλλαγών των εδαφών διαδραματίζουν σημαντικό 

ρόλο για τον εντοπισμό και την κατανόηση της ανθεκτικότητας των οικοσυστημάτων.  

Οι δορυφορικές μέθοδοι παρατήρησης της Γης είναι μία από τις καλύτερες προσεγγίσεις για 

την παρακολούθηση αυτών των αλλαγών τόσο σε τοπική, περιφερειακή όσο και σε 

παγκόσμια κλίμακα. Ως περιοχή μελέτης στην συγκεκριμένη άσκηση ορίζεται η Κύπρος. 

2. Δεδομένα - Εγγραφή στην Υπηρεσία 
Τα δεδομένα Copernicus είναι ανοιχτά και σε ελεύθερη πρόσβαση σε όλους τους χρήστες με 

την προϋπόθεση να έχουν κάνει μια απλή και εύκολη εγγραφή στην Υπηρεσία. Για την 

περαιτέρω επεξεργασία των δορυφορικών χαρτών και δεδομένων, διατίθεται δωρεάν το 

λογισμικό SNAP από τον Ευρωπαϊκό Οργανισμό Διαστήματος (ESA). 

Χρήσιμες Συνδέσεις. 

Ανάκτηση δορυφορικών δεδομένων: https://scihub.copernicus.eu 

Λογισμικό SNAP: https://step.esa.int/main/download/snap-download/ 

3. Λήψη – Ανάκτηση δορυφορικών δεδομένων 
Για την λήψη των δορυφορικών δεδομένων της περιοχής που θα μελετήσουμε, 

μεταβαίνουμε στην ιστοσελίδα https://scihub.copernicus.eu/  κι έπειτα στην επιλογή ‘Open 

Hub’ (Εικόνα 1) 

 
Εικόνα 1: Η πλατφόρμα των ελεύθερων δεδομένων του Copernicus. 

Στη συνέχεια, εφόσον έχουμε ολοκληρώσει την εγγραφή μας στην υπηρεσία, μπορούμε να 

πραγματοποιήσουμε είσοδο. Επιλέγοντας το σημείο πάνω δεξιά (κίτρινο βέλος), ανοίγει ένα 

καινούριο παράθυρο διαλόγου όπου βάζοντας τα Username και Password ουσιαστικά 

κάνουμε την είσοδο μας στην υπηρεσία (Εικόνα 2). 
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Εικόνα 2: Είσοδος στην υπηρεσία του Copernicus 

4. Μέθοδος ανάκτησης δορυφορικών δεδομένων 
Με την είσοδο μας στην υπηρεσία του Copernicus διαπιστώνουμε πως έχουμε ανοικτή 

πρόσβαση σε όλα τα προϊόντα των δορυφόρων Sentinel-1, Sentinel-2, Sentinel-3 και Sentinel-

5P. Στην συγκεκριμένη άσκηση θα χρησιμοποιήσουμε δορυφορικές εικόνες από τον Sentinel-

3. 

Για την ανάκτηση των εικόνων μας το πρώτο βήμα είναι να σχηματίσουμε ένα πολύγωνο 

επάνω από την περιοχή μελέτης μας (Κύπρος) πατώντας το σύμβολο δεξιά στην οθόνη μας 

όπως φαίνεται στην παρακάτω εικόνα 3. Δεύτερο βήμα είναι ο καθορισμός των παραμέτρων 

που θα συμπληρώσουμε για να κατεβάσουμε ορθά την εικόνα. 

Sensing period: 2023/01/09 – 2023/15/09 

Check Mission: Sentinel-3 

Product Type: OL_1_EFR__ 

Instrument: OLCI 

Product Level: L1 

Εικόνα 3:  Δημιουργία πολυγώνου     Εικόνα 4: Καθορισμός δεδομένων 
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Το τελευταίο στάδιο της διαδικασίας αφορά το κατέβασμα των παρακάτω εικόνων. 

2023-09-05 
S3A_OL_1_EFR____20230905T081239_20230905T081539_20230906T084547_0179_103_078_2340_PS1_O_NT_003.SEN3 

2023-09-09 
S3A_OL_1_EFR____20230909T080855_20230909T081155_20230909T100915_0179_103_135_2340_PS1_O_NR_003.SEN3 

2023-09-13 
S3A_OL_1_EFR____20230913T080512_20230913T080812_20230913T100557_0179_103_192_2340_PS1_O_NR_003.SEN3 

5. Εισαγωγή δορυφορικής εικόνας στο λογισμικό SNAP 

(Open Product) 
Αφού ανακτήσουμε τις δορυφορικές εικόνες που μας ενδιαφέρουν, για την περαιτέρω 

επεξεργασία τους θα τις εισαγάγουμε στο λογισμικό επεξεργασίας δορυφορικών εικόνων 

SNAP. Αρχικά θα πρέπει να αποσυμπιέσουμε (Unzip) τα αρχεία μας. 

Στην συνέχεια στο περιβάλλον που εμφανίζεται για να εισαχθεί η δορυφορική εικόνα, από 

την οριζόντια εργαλειοθήκη του προγράμματος επιλέγουμε την εντολή Open Product και 

στην συνέχεια ανοίγουμε το xml αρχείο (Εικόνα 5Α–5Β). Επαναλαμβάνουμε την ίδια 

διαδικασία και για τις υπόλοιπες δορυφορικές εικόνες μας.  

Για το άνοιγμα της εικόνας επιλέγουμε το αρχείο της εικόνας και με δεξί κλικ επιλέγουμε το 

Open RGB Image (Εικόνα 6). 

 

Εικόνα 5Α. Εισαγωγή της δορυφορικής εικόνας στο SNAP    Εικόνα 5Β. Εισαγωγή xml αρχείου 

 

6. Subset (Αποκοπή εικόνας) 
Στη συνέχεια, θα πρέπει να μειώσουμε τη χωρική έκταση των εικόνων μας και να εστιάσουμε 

στην περιοχή μελέτης μας που είναι η Κύπρος. Στόχος της αποκοπής αποτελεί η μείωση του 

μεγέθους των εικόνων ώστε να είναι ταχύτερη η επεξεργασία τους από το SNAP. 

Από την εργαλειοθήκη επιλέγουμε την εντολή Raster-> Subset. (Εικόνα 6) 

Στην συνέχεια στο νέο παράθυρο που μας εμφανίζει η εφαρμογή εντός του χάρτη 

δημιουργούμε ένα νέο πλαίσιο επικεντρώνοντας στην περιοχή της Κύπρου. 



 

6 
 

 

Εικόνα 6. Αποκοπή εικόνων στο SNAP 

7. Επεξεργασία δορυφορικής εικόνας στο λογισμικό SNAP 
Επιλέγουμε την παρακάτω παλέτα χρωματικών καναλιών ώστε να δημιουργήσουμε την 

εικόνα μας.  
Red: Oa08_radiance 

Green: Oa06_radiance 

Blue: Oa04_radiance 

Στη συνέχεια για να την βελτιώσουμε, μπορούμε να αλλάξουμε την κατανομή χρώματος για 

κάθε ζώνη RGB στην καρτέλα Colour Manipulation. Επιλέγουμε αρχικά το κόκκινο κανάλι και 

σέρνοντας τον δρομέα τον τοποθετούμε περίπου στην τιμή 180 (Εικόνα 7). Αλλάζουμε το 

πράσινο κανάλι στην τιμή περίπου 160 και το μπλε κανάλι στην τιμή 150. 



 

7 
 

Εικόνα 7. Άνοιγμα εικόνων και ρύθμιση των χρωματικών καναλιών 

 

 

Εικόνα 8: Αλλαγή κατανομής χρώματος ανά κανάλι 

 

8. Γράφημα μεθοδολογίας (Graph Builder) 
Στο επόμενο στάδιο, μπορούμε να δημιουργήσουμε ένα γράφημα που θα περιέχει όλα τα 

βήματα της μεθοδολογίας μας, ενώ μέσω της εφαρμογής του SNAP θα εκτελέσουμε μαζική 

επεξεργασία των εικόνων. Αρχικά, πρέπει να ανοίξουμε ένα κενό γράφημα. 

Από την εργαλειοθήκη επιλέγουμε Tools-> Graph Builder (Εικόνα 9). 

Προς το παρόν, το γράφημα έχει μόνο δύο τελεστές: Read και Write.  

Προς το παρόν δεν θα χρειαστούμε τον τελεστή Write, επομένως μπορούμε να τον 

διαγράψουμε επιλέγοντας τον και με δεξί κλικ να επιβεβαιώσουμε την επιλογή μας. 
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Εικόνα 9: Εισαγωγή γραφήματος μεθοδολογίας 

9. IdePix Processor 
Το πρώτο βήμα της μεθοδολογίας μας θα έχει ως στόχο την αφαίρεση από την εικόνα των 

εικονοστοιχείων (pixels) τα οποία απεικονίζουν σύννεφα. 

Θα χρησιμοποιήσουμε τον αλγόριθμο IdePixProcessor που είναι διαθέσιμος στο SNAP, ο 

οποίος μας παρέχει  ταξινόμηση των pixel σε ιδιότητες όπως καθαρό/νεφελώδες, γη/νερό, 

χιόνι, πάγος κ.λπ. Για να προσθέσετε τον αλγόριθμο, κάντε δεξί κλικ στη λευκή περιοχή του 

γραφήματος και επιλέγουμε την διαδρομή: Add-> Optical-> Preprocessing-> Masking-

>IdePix->IdePix.Olci (Εικόνα 10). 

Στην συνέχεια με δεξί κλικ πάνω στον τελεστή Read επιλέγουμε την εντολή Connect Graph 

(Εικόνα 11). 

 

Εικόνα 10: IdePixProcessor 

 

Εικόνα 11: Connect Graph 
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10. BandMath 
Το επόμενο βήμα επεξεργασίας θα είναι η δημιουργία του κανονικοποιημένου δείκτη 

βλάστησης (NDVI) για τα pixels που δεν έχουν ταξινομηθεί ως σύννεφα από τον επεξεργαστή 

IdePix και δεν είναι επίσης pixels νερού. 

Ο κανονικοποιημένος δείκτης βλάστησης (NDVI) είναι ένας δείκτης που υπολογίζει την 

ζωτικότητα της βλάστησης και βασίζεται σε δορυφορικά δεδομένα.  

Για την ολοκλήρωση της εργασίας, θα χρησιμοποιήσουμε τον τελεστή Band Math. 

Επιλέγουμε από την εργαλειοθήκη Add->Raster->BandMaths (Εικόνα 12). Όπως και 

προηγούμενα ενώνουμε το γράφημα. 

 

Εικόνα 12: BandMath 

11. Reproject (Επαναπροβολή) 
Το τελευταίο βήμα στο γράφημα μας θα είναι η προσθήκη του αλγόριθμου Reproject. Ο 

συγκεκριμένος θα μας εξασφαλίσει πως όλες οι εικόνες μας ανήκουν στο ίδιο σύστημα 

προβολής συντεταγμένων. Με απλά λόγια, η εντολή reproject μας βοηθά να μετατρέψουμε 

την τρισδιάστατη απεικόνιση (πχ. από ένα σφαιρικό σύστημα συντεταγμένων) σε 

δισδιάστατη απεικόνιση δηλαδή μεταφορά της πληροφορίας σε χάρτη αποδίδοντας για κάθε 

σημείο της αρχικής προβολής σε γεωγραφικό μήκος και πλάτος. 

Με δεξί κλικ στο γράφημα μας επιλέγουμε Add->Raster-> Geometric->Reproject. (Εικόνα 

13). Όπως και προηγούμενα συνδέουμε το γράφημα μας. 

Τέλος για να ολοκληρωθεί το γράφημα μας 

θα προσθέσουμε και τον τελεστή Write, 

επιλέγοντας Add-> Input-Output->Write.  
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Εικόνα 13: Reproject 

12. Batch Processing (Μαζική Επεξεργασία Εικόνων) 
Αρχικά θα πρέπει να ανεβάσουμε στο SNAP όλες τις δορυφορικές εικόνες μας. Με σκοπό να 

μην επεξεργαστούμε κάθε εικόνα μας χωριστά και μία μία θα δημιουργήσουμε στο SNAP ένα 

πακέτο με τις τρείς εικόνες μας.  

Από την εργαλειοθήκη του προγράμματος επιλέγουμε Tools-> Batch Processing (Εικόνα 14). 

Επιλέγουμε το εικονίδιο Add Opened (δεύτερη επιλογή από την κορυφή) και επιλέγουμε και 

το εικονίδιο Refresh. Στην συνέχεια από την επιλογή Load Graph φορτώνουμε το Graph 

αρχείο μας που αποθηκεύσαμε σε προηγούμενο βήμα (Εικόνα 15). 

 

Εικόνα 14: Batch Processing 



 

11 
 

 

Εικόνα 15: Load Graph 

Στην καρτέλα Idepix.Olci, βεβαιωθείτε πως έχετε επιλέξει όλα τα κανάλια στο σημείο που 

ονομάζεται: Select TOA reflectance to write to the target product (Εικόνα 16). 

Με αυτόν τον τρόπο, ο αλγόριθμος IdePix θα μας δώσει τιμές pixel σε ανάκλαση και όχι από 

ακτινοβολία. Με τον όρο ανάκλαση εννοούμε την αναλογία της ποσότητας φωτός που 

αφήνει ένα στόχο προς την ποσότητα φωτός που χτυπά τον στόχο. Η ανάκλαση είναι μια 

ιδιότητα του εκάστοτε υλικού που παρατηρείται. Η ακτινοβολία, από την άλλη πλευρά, 

εξαρτάται από τον φωτισμό (τόσο την ένταση όσο και την κατεύθυνσή του), τον 

προσανατολισμό και τη θέση του στόχου που μελετάται καθώς και από τη διαδρομή του 

φωτός μέσα στην ατμόσφαιρα. Με απλά λόγια η ακτινοβολία αφορά το πόσο φως «βλέπει» 

το όργανο μέτρησης από το αντικείμενο που μελετάται. 

 

Εικόνα 16: Παράμετροι για το Idepix.Olci. 

Ακολούθως επιλέγουμε την καρτέλα BandMaths. Στην επιλογή Target band γράφουμε NDVI. 

Στην επιλογή Set the No-Data γράφουμε NaN, και τέλος στην επιλογή Edit Expression 

κάνουμε αντιγραφή – επικόλληση την παρακάτω έκφραση:  
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if IDEPIX_CLOUD == TRUE or IDEPIX_LAND == FALSE then 0 else (Oa17_reflectance-

Oa08_reflectance)/(Oa17_reflectance+Oa08_reflectance) (Εικόνα 17). 

Με απλά λόγια η παραπάνω έκφραση ταξινομεί και μετατρέπει όλα εκείνα τα εικονοστοιχεία 

(pixels) των συννέφων των δορυφορικών εικόνων μας σε πολλαπλών ιδιοτήτων 

εικονοστοιχεία όπως για παράδειγμα (γη και σύννεφα, γη και χιόνι, χιόνι και σύννεφα κα.). 

Στην προκειμένη έκφραση όποια εικονοστοιχεία δεν είναι γη τα δίνουμε τιμή ίση με το 

κανονικοποιημένο δείκτη βλάστησης NDVI. 

 

Εικόνα 17: Παράμετροι για το BandMaths 

Στην καρτέλα Reproject Tab, στην επιλογή Custom CRS για να ορίσουμε το σύστημα 

προβολής συντεταγμένων επιλέγουμε: UTM/WGS 84 (Automatic). 

 

Εικόνα 18: Παράμετροι για το Reproject 

Στο τελικό στάδιο στη καρτέλα Write, επιλέγουμε σε ποιο φάκελο θα αποθηκεύσουμε το 

τελικό αποτέλεσμα και επιλέγουμε Run (Εικόνα 19). 
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Εικόνα 19: Τελικό στάδιο επεξεργασίας 

13. Εικόνες NDVI 
Ο κανονικοποιημένος δείκτης βλάστησης (NDVI) είναι ευαίσθητος στην περιεκτικότητα της 

βλάστησης σε χλωροφύλλη. Οι υψηλές τιμές NDVI δείχνουν υψηλή περιεκτικότητα σε 

χλωροφύλλη της βλάστησης. Οι τιμές του κυμαίνονται μεταξύ του -1 και του +1. 

Για παράδειγμα, όταν έχουμε αρνητικές τιμές, είναι πολύ πιθανό να έχουμε νερό στο σημείο 

που μελετάμε. Από την άλλη πλευρά, εάν έχουμε μια τιμή NDVI κοντά στο +1, υπάρχει 

μεγάλη πιθανότητα να έχουμε πυκνά - υγιή πράσινα φύλλα. Όταν το NDVI είναι κοντά στο 

μηδέν, πιθανότατα δεν υπάρχει υγιής βλάστηση ή ενδεχόμενα θα μπορούσε να είναι μια 

περιοχή αστικής ανάπτυξης.  

Ο δορυφόρος Sentinel-3 το οποίο χρησιμοποιούμε στην παρούσα άσκηση αποτελείται από 

21 κανάλια (Bands). Κάθε κανάλι εξ αυτών επιλέγεται ανάλογα με το φαινόμενο που θέλουμε 

να μελετήσουμε. Για την εξαγωγή δεδομένων για τον κανονικοποιημένο δείκτη βλάστησης 

χρησιμοποιείτε η παρακάτω εξίσωση στην οποία περιλαμβάνονται τα κανάλια Β8 και Β4 του 

δορυφόρου. 

NDVI = (B8-B4)/(B8+B4) 

Σε συνέχεια της άσκησης μας και αφού έχει ολοκληρωθεί η προηγούμενη εντολή μας 

διαπιστώνουμε πως έχουν δημιουργηθεί 3 νέες εικόνες. Με δεξί κλικ σε κάθε νέα εικόνα και 

στο φάκελο NDVI επιλέγουμε Open Image Window. 

Στο σημείο που δείχνει το βέλος στην Εικόνα 20 επιλέγουμε να βλέπουμε και τις τρεις εικόνες 

ταυτόχρονα είτε σε οριζόντια είτε σε κάθετη προβολή. 

Για να βλέπουμε και τις τρείς εικόνες μας με την ίδια παλέτα χρωμάτων από την επιλογή 

Colour Manipulation μεταβαίνουμε στην επιλογή Palette και διαλέγουμε το χρωματικό 

συνδυασμό της προτίμησης μας. 
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Εικόνα 20: Άνοιγμα εικόνων NDVI 

14. Χρονοσειρά – Time series 
Το SNAP προσφέρει εργαλεία ανάλυσης χρονοσειράς κατάλληλα για την αναπαράσταση της 

χρονικής εξέλιξης διάφορων δεικτών – παραμέτρων. Στην άσκησή μας, με την επεξεργασία 

που πραγματοποιήσαμε μπορούμε να εξετάσουμε – παρατηρήσουμε τις όποιες αλλαγές 

εντοπίζονται στον δείκτη NDVI για την περίοδο που εξετάζουμε στην περιοχή μελέτης μας. 

Για να προχωρήσουμε στην παρατήρηση και ανάλυση των αλλαγών του δείκτη στην χρονική 

περίοδο που εξετάζουμε από την κεντρική εργαλειοθήκη του προγράμματος επιλέγουμε το 

Time Series Analysis (Εικόνα 21). 

Στο παράθυρο που μας εμφανίζεται πλέον δεξιά κάτω του προγράμματος επιλέγουμε στην 

συνέχεια στο αναδυόμενο παράθυρο το add all και επιλέγουμε τις 3 τελευταίες εικόνες μας 

του NDVI που δημιουργήσαμε στο προηγούμενο βήμα. Επιλέγουμε το Apply και κλείνουμε 

το προηγούμενο παράθυρο. 
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Εικόνα 21: Διεργασία  Χρονοσειράς για τον δείκτη NDVI 

Από την τρίτη επιλογή στα δεξιά του time series παράθυρου, επιλέγουμε τον δείκτη NDVI  

στο παράθυρο που μας ανοίγει τελικά μπορούμε να διαπιστώσουμε πως παίρνουμε ένα 

γράφημα που αποτυπώνει τις όποιες αλλαγές στην ζωτικότητα της βλάστησης στην Κύπρο 

και πάντα για την περιοχή μελέτης μας εντός πάντα του χρονικού διαστήματος που 

μελετήσαμε (Εικόνα 22). 

 

Εικόνα 22: Αποτέλεσμα Γραφήματος Χρονικής Εξέλιξης του NDVI. 


